Analisis bloque de alimentacion de los equipos DELL

Avatar de Usuario
2informaticos
ReballingAdicto!!
Mensajes: 2637
Registrado: Mar Abr 13, 2010 5:55 pm
Máquina: ACHI-IR-PRO + JOVY RE-7500
Ubicación: Madrid [en la foto, soy el de pelo corto]

Analisis bloque de alimentacion de los equipos DELL

Mensajepor 2informaticos Mié Jul 06, 2011 3:03 pm

Saludos compañeros,
aprovecho una reparacion de un portatil Dell Inspiron 9400, recien finalizada, para dejar otro tutorial.
Esta vez se trata del bloque de entrada de estos equipos, con referencia directa al pin central del cable AC.
Me meti un poco en lio con este equipo al no indagar en Internet sobre la señal PWR_ID desde principio...
Para empezar, el equipo funcionaba perfectamente con bateria, pero no la cargaba y en BIOS tampoco reconocia el cargador.
El esquema usado es Compal LA-2881P, el mismo que el modelo XPS M1710.

En la pagina 43, podemos ver los bloques +DC_IN Source y PS_ID Detector.
La primera vista, faltaba la bobina PL2. Alguien habia trabajado antes en el equipo, pero ya me lo habia dicho y sabia que no hizo tonterias.
Al soldar dicha bobina consegui las tensiones +DC_IN_SS y +PWR_SRC. Tambien pude comprobar la presencia de +3.3V_ALW y +5V_ALW, que son las salidas de baja potencia del circuito MAX8734A.
He de mencionar que solo uno de los MOSFET PQ3 o PQ4 esta en la placa; revisar la tabla de las @...

El equipo no queria prender todavia. Aqui me equivoque; en vez de seguir el hilo logico, e ir a por la zona del MAX8731, empeze a meterme al fondo con la señal PWR_ID. He de mencionar que al final tocaba trabajar esta zona tambien, pero no tenia que asociar la falla completamente e unicamente con esta zona.
Empeze "fallar" desde el principio; midiendo la tension del pin central PWR_ID. Yo esperaba encontrar aqui alguna tension, algo similar a los equipos HP con pin central en el cargador AC. Nada mas decir que comprobe con 4 cargadores diferentes y en ninguno no tenia mas de 0.1-0.2V en este pin; con el cable libre, o enchufado era lo mismo...
Con el cargador conectado, al presionar el boton de power, pude comprobar la presencia de una tension de 3.3V en DOCK_PSID; solo para el tiempo que el boton se quedaba apretado.

En mi equipo faltaban la dioda PD53 y la resistencia PR151; en la primera pagina del esquema hay una tabla de versiones, segun las marcas @...
Esto me hizo pensar que el transitor PQ1 estaba bien; recibia +5V_ALW en G y dejaba pasar los 3.3V_ALW D-S. Me empeñe medir mas componentes en la zona y encontre la resistencia PR2 con un valor inapropiado, mas de 30k; revise otros esquemas Dell y vi que 33 ohmios era el valor correcto. La cambie, pero el equipo seguia sin funcionar con el cargador.

Entonces fue cuando decidi buscar por Internet, a ver si podia conseguir mas informacion sobre la señal PWR_ID; o PS_ID, da igual como la nombrais.
Ya se hizo luz, al ver que dicha señal no es (solo) una barra de tension, sino una linea de datos tambien. Si, por esa señal el equipo comunica directamente con el cargador; el que tiene dentro una memoria de tipo "1-wire", donde tiene almacenada la informacion necesaria para que el equipo reconozca la potencia del cargador.
Cuando se apreta el boton de power, la tension +3.3V_ALW del equipo llega a la memoria del cargador y empieza el cambio de informacion; todo se hace por la misma linea, que sirve tanto para alimentacion, como para intercambio de datos. Se puede encontrar informacion en Internet sobre el protocolo usado. Yo me base en esta pagina
http://www.chargerbuy.com/blog/expert%E ... %E2%80%9D/
Entendi entonces porque no encontraba ninguna tension en el pin central con el cargador desenchufado, o sin apretar el boton de power.

La similitud de estos cargadores con los de HP me hizo pensar muy mal desde principio.
Recordando que la resistencia PR151 la encontre con valor muy alto, me hizo pensar que algo paso con la linea PS_ID y, quizas, el equipo ya no funcionara nunca mas con cargador. El hecho de que el transistor PQ1 funcionaba bien, aun con la resistencia desvalorizada, me dio las ganas para seguir trabajando con el equipo.

Aqui empeze pensar un poco mas logico y me fui a comprobar la zona del MAX8731A. Y que gran sorpresa; encontre la señal ACIN con solo 1.5V. La hoja del fabricante especifica un valor 2.048V para que el MAX8731 reconozca el cargador. Un simple calculo sobre el divisor PR131+PR133 daba como resultado unos 2.5V.
Aunque pensaba que el MAX8731 consumia demasiado por esta entrada, lo que lo indicaba como mal, hice un intento mas de subir el valor de esa señal; el fabricante especifica como valor maximo 6V. Solde una resistencia de 470k en paralelo con PR131 y la señal subio a 2.6V, pero el equipo seguia sin reconocer el cargador. Cuando detecta el cargador, el circuito MAX8731 sube la señal ACOK a 3V; habia comprobado ya las resistencias PR132 y PR135...
Entonces, unicamenta resultaba que el MAX8731A estaba mal. Lo cambie y el equipo empezo a funcionar normal, con cargador.

El vinculo de Internet dejado mas arriba, les explica como hacer que un equipo Dell funcione con cualquier cargador; es decir, sin pin central...
Para esto se necesita soldar dentro del equipo una memoria de cualquier cargador Dell; preferiblemente una de un cargador con potencia correspondiente, para que no le moleste con el aviso de potencia, cada vez que enciendan el equipo.

Espero que mas de uno sacara un minimo provecho de la informacion posteada.
Saludos y suerte.
Última edición por 2informaticos el Jue Jul 07, 2011 5:46 am, editado 1 vez en total.
ACHI IR-PRO + JOVY RE-7500
ATTEN AT860D + MLINK H1 + AOYUE Int 768
JBC BD 1A-C + HAKKO 701 + ATTEN AT201D


¡¡¡Por favor, busquen bien el foro antes de plantear sus dudas. 90% de las preguntas ya tienen respuesta!!!
Avatar de Usuario
Calor_IR
Extractor
Mensajes: 155
Registrado: Vie Mar 04, 2011 5:06 pm
Máquina: Cerebral
Ubicación: Venezuela

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor Calor_IR Jue Jul 07, 2011 5:27 am

Vaya vuelton distes 2informaticos, a veces sucede y no se por cual razón, perdemos la lógica con la cual nos desenvolvemos en este tipo de situación, peor al final ta ta ta tan !!!! el resultado efectivo, mil gracias por tu aporte :!: :!: :!:
"Todos somos ignorantes, lo que sucede es que no todos ignoramos las mismas cosas"
azuipr
Pop Corn
Mensajes: 74
Registrado: Mar Jun 21, 2011 7:30 pm
Máquina: achi ir-pro-sc

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor azuipr Jue Jul 07, 2011 11:18 am

gracias por compartir
mui buen post e la explication detllada si me viene una idntico ya sabre como lo resolver
a propocito sabes si ai una tienda en españa que venda los chips max
gracias
DSS-LAP
Reboleador
Mensajes: 473
Registrado: Sab Jul 31, 2010 7:32 pm
Máquina: ZM-R5830

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor DSS-LAP Dom Jul 10, 2011 11:45 pm

Fantástico gracias como siempre

salu2
ZM-R5830 FUNCIONANDO...
Avatar de Usuario
abrapy
Pop Corn
Mensajes: 52
Registrado: Sab Abr 30, 2011 2:06 pm
Máquina: JOVY

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor abrapy Sab Jul 23, 2011 5:04 pm

que seria de nosotros sin la ayuda de 2informaticos

siempre trayendo luz a nuestras mentas

gracias maestro!
Carloscpm
Hot Gun
Mensajes: 14
Registrado: Dom Jun 26, 2011 5:28 pm
Máquina: no tengo aun

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor Carloscpm Sab Jul 23, 2011 7:01 pm

Antes que nada mis saludos 2informaticos..le he seguido desde hace varios meses sus post y he elejido este en especial,para felicitarlo por su ejemplo de perseverancia, conocimiento y enseñanza desinteresada.
Compartir el conocimiento es lo que nos engrandece y nos hace más sabios.
Aprovecho esta instancia también, para reconcer a muchos en este Sitio por su entrega pedagógica de sus experiencias en esta fascinante área de la electrónica.
Llamo a quienes usufructuamos y aprendemos de Maestros como 2informaticos y otros,que cuando encontremos la solución a las fallas las publiquemos y asi llegar,algún día a superar al Maestro.....dificil, pero un gran desafío.
luisfelipezz
manteca
Mensajes: 295
Registrado: Mar Dic 21, 2010 7:50 pm
Máquina: casero
Ubicación: Tarija-Bolivia

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor luisfelipezz Lun Ago 29, 2011 6:42 pm

hola a todos
me sumo a carloscpm, muy didactico gracias 2informaticos
Martet
Reboleador
Mensajes: 324
Registrado: Mar Oct 06, 2009 12:54 pm

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor Martet Mar Ago 30, 2011 4:25 pm

Te felicito por todo el analisis que hicieste al circuito... es algo que habitualmente no hago, auqnue si hubieses preguntado que podia ser lo que hacia que no se reconociera el cargador, te hubiera dicho que reemplazaras dicho maxim (es bastante comun en los dell que vuele).
Ahora, te hago una pregunta a ver si podes darme una mano. Recibi una Inspiron 1545 que tenia un mosfet en corto (de alimentacion de micro), y el 8731AE dañado. Reemplace todo y la maquina quedo funcionando casi a la perfeccion, a no ser por una cosa...... Si esta conectado el cargador y la bateria, la maquina funciona perfectamente, solo que al poner "APAGAR EL EQUIPO", en vez de apagar, se reinicia. Si trabaja solo con cargador o solo con bateria, al apagar el equipo, este apaga perfectamente. Ya cambie el KBC, el ISL6266, y varias cosas mas, ya que no tengo siquiera idea que puedo medir para ver que esta pasando. Un abrazo y gracias.
P.D., no es un problema de Soft.
Avatar de Usuario
reyessuper
Reboleador Extremo
Mensajes: 640
Registrado: Mié Jul 28, 2010 4:25 pm
Máquina: Shuttle Star SP360C
Ubicación: Vitoria - España

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor reyessuper Mar Ago 30, 2011 6:56 pm

Gracias Maestro :!: :!:
Sustitución Chip Gráficos - Reparación Placas Base

Peligro!! .... Shuttle Star SP360C V2 a pleno rendimiento :lol:

Chaco
Hot Gun
Mensajes: 21
Registrado: Jue May 19, 2011 9:29 pm
Máquina: JOVY-RE-7500

Re: Analisis bloque de alimentacion de los equipos DELL

Mensajepor Chaco Mar Ago 30, 2011 8:26 pm

Grande Genio!!!

Con las sony, pasa la mismo?

Volver a “Ordenadores portátiles”